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Corrigo Integration Client for 
QuickBooks -- User Guide 

Overview 

This guide explains how to implement the Corrigo Integration Client for QuickBooks. The following 
assumptions apply to the use of this guide: 

• You utilize QuickBooks as your business accounting software (see System Requirements in this 
guide for additional information) 

• Your QuickBooks application runs on a computer that has Internet access. 

• You have a valid URL, user ID, and password for your Corrigo WorkTrack Service Management 
product. 

• You have a basic understanding of how to access, navigate, and use both QuickBooks and your 
Corrigo product. 

Using This Guide 

Appearance: Since your company can customize Service Management by changing 
screen appearance, words, and phrases used in the application, some 
images used in this guide may not exactly match those that appear on 
your screens.  

Conventions: The Corrigo WorkTrack Service Management product you use will be 
referred to as WorkTrack, Service Management, the web application, or 
just application within this guide. All supported versions of QuickBooks 
will be referred to merely as QuickBooks, unless otherwise noted. The 
Corrigo Integration Client for QuickBooks will be referred to as the 
integration client. 

Path Reference: Path references will be used in this guide to direct you to the appropriate 
screen within your software products. For example, to reach the client 
download screen in Service Management, the path is Settings > Company 
> Integration. This means that, within your WorkTrack Service 
Management web application, you select the Settings page, choose the 
Company tab on that page, then select the Integration option from the 
Company menu. 
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System 
Administrator: This is the person at your company who manages your Service 

Management and QuickBooks programs. The term System Administrator 
is used in this guide. 

System Requirements 

Minimum system requirements:  

• At least 1.6 GHZ Processor 

• 1 GB of RAM 

• 1GB Available Hard-Disk Space 

• 1024 X 768 Screen Resolution 

QuickBooks versions supported: The Corrigo Integration Client can be used with the following 
QuickBooks versions:  

• Simple Start, Pro, Premier, and Enterprise versions from 2007 and newer, running on Microsoft 
Windows XP, and Vista Business or Ultimate operating systems (32 bit and 64 bit). 

Note: QuickBooks 2007 and newer versions support Windows Vista. All previous versions of 
QuickBooks are not supported to run on Vista. 

(see http://developer.intuit.com/developer/newsletter.asp?id=504 for details) 

Important for Vista Users:  Read Running the Corrigo Integration Client on Vista in this guide for 
directions on how to properly load the client on a computer running Microsoft Vista Business or Ultimate 
(client will not run on any Vista Home edition). 
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Installing the Corrigo Integration Client 

Overview 

In order to integrate Service Management with your QuickBooks accounting system, you will first need 
to install the Corrigo Integration Client for QuickBooks. Once installed, the integration client will enable 
you to synchronize customers and items, export/update web application invoices and payments to 
QuickBooks, and map payment methods between the two systems. Time Card users can export time card 
information. 

Important for Vista Users:  Before proceeding, read Running the Corrigo Integration Client on Vista in 
this guide for directions on how to properly load the Corrigo Integration Client on a computer running 
Microsoft Vista Business or Ultimate (client will not run on any Vista Home edition). 

To Install the Corrigo Integration Client: 

1. Log into Service Management from the computer that contains your QuickBooks software. 

2. Within the web application, go to Settings > Company >  Integration. 

 
Figure 1: Click Edit to turn on QB Integration 

 

3. Click Edit on “Do you want to integrate with QuickBooks?” 
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4. Select Yes and click on Save.  

 

5. Click on Edit for Integration Client Authentication Code 

 

6. Enter a code, re-enter to confirm and click on Save. 

 

7. Click Install Corrigo QuickBooks Integration Client (this button becomes active once Step 6 is 
completed). 

 

8. You will be presented with the option to Run or Save the file setup.exe. Choose Run. 
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Figure 2: Sample File Download screen from Microsoft Windows XP Media Center Edition, version 

2002 

Note: Depending upon your operating system and security software, you may receive additional 
messages. In general, choose options that allow you to accept and run this file from Corrigo  

9. You will be greeted by the setup program. Close your QuickBooks application and click Next. 
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Figure 3: Close QuickBooks and click Next when this screen appears 

10. Click through the setup program as prompted.  

Note: You will be given the option to choose your own folder where the client files will be 
installed. Corrigo recommends that you choose the default option unless otherwise directed. 
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Figure 4: Corrigo recommends choosing the default installation folder  

11. Click Close when you receive a message stating that installation is complete. 

Your Corrigo Integration Client for QuickBooks is now installed and available for use within 
QuickBooks. It will launch the next time you open your QuickBooks company. 

Automatic Update of the Corrigo Integration Client 

Once your Corrigo Integration Client is installed, it will automatically check for updates each time you 
launch QuickBooks and open the company file. If a newer version of the client exists, you will be 
prompted to upgrade. Click Yes to upgrade when prompted. 
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Figure 5: If a newer version of the Corrigo Integration Client exists, you will be prompted to 

upgrade (top). Click Finish when done (bottom). 

Once the upgrade is completed, click Finish. You will not need to re-boot your computer. 

Uninstalling the Corrigo Integration Client 

If you need to uninstall the client, go to your Windows Control Panel > Add or Remove Programs, then 
find the item labeled Corrigo Integration. Highlight this item, then click Remove. Follow prompts to 
remove the program from your computer. 

Note: Vista users will go to Control Panel > Programs and Features, select Corrigo Integration, then click 
Uninstall at the top of the window. Follow prompts to remove the program from your computer. 
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Initial Synchronization Setup 

Overview 

Once the client is installed, you will need to make sure that your system has enough memory and free 
disk space. Follow these steps to check your system. 

• Launch QuickBooks 

• Click on File menu�Corrigo Integration�About 

• About Corrigo Integration dialog box will pop up. Click on Perform System Requirements 
Check hyperlink. System requirements check dialog will pop up. If you get green check that 
means your system passed the check. If not we highly recommend you to upgrade your 
computer before proceeding with the integration. Please refer system requirements section above 
for minimum system requirements. 

 
Figure 6: System check 
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• Click on Ok 

Next you will need to configure settings for integration between Service Management and QuickBooks. 
This consists of deciding how various fields and functions will associate between the two systems. Setup 
is completed through the Initial Synchronization Setup Wizard, which will walk you through each step. 

If you want to synchronize inventory tracking between QuickBooks and Service Management: 
Prior to running the setup wizard, you must activate inventory tracking in QuickBooks. See 
QuickBooks Settings for Inventory Tracking below for additional information. 

Time Card users: Prior to running the setup wizard, you must make adjustments to your 
QuickBooks configuration. See QuickBooks Settings for Time Card Users below. 

Note: If your company is running QuickBooks in multi-user mode, make sure the user running the 
synchronization is logged in as an administrator and has rights to access external applications. See your 
QuickBooks documentation for information on how to set user rights. 

QuickBooks Settings for Inventory Tracking 

Service Management allows you to synchronize QuickBooks inventory items for inventory tracking. 
Inventory Items are items for which you track quantities purchased, on-hand, and sold. You can create 
inventory items in QuickBooks and export them into Service Management. Any inventory item sold in 
Service Management will be decremented from the inventory tracking count in QuickBooks. 

If you want to set up the Corrigo Integration Client to synchronize inventory items, you must activate 
Inventory and Purchase Orders within QuickBooks. To do this, go to Edit > Preferences > Items & 
Inventory > Company Preferences, then check Inventory and purchase orders are active (this is the 
location in most versions of QuickBooks. Consult your QuickBooks documentation if Company 
Preferences is not found on this path for your version). 

After activating inventory tracking, set up inventory items within QuickBooks so that they can export to 
Service Management (see QuickBooks documentation to learn how to set up inventory items). 

Note: Items added directly to Service Management as Price List Inventory Items will not export into 
QuickBooks and cannot be used in Service Management invoices to decrement the QuickBooks inventory 
count. Inventory Items must be set up in QuickBooks initially, then exported to Service Management. 
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Figure 7: In QuickBooks, go to Edit > Preferences > Items & Inventory > Company Preferences and 

check Inventory and purchase orders are active in order to synchronize inventory items with Service 

Management 

QuickBooks Settings for Time Card users 

Prior to running the Initial Synchronization Setup Wizard, Time Card users must configure QuickBooks 
for synchronization. 

First, you must set up QuickBooks payroll items to associate with Service Management hourly rates. This 
can be accomplished through the Change New Employee Default Settings feature within QuickBooks. 
Refer to your QuickBooks documentation for additional information. 
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Figure 8: Sample of Employee Default Settings Screen from QuickBooks Premier 2007 

Next, you need to configure QuickBooks to allow the Corrigo Integration Client access to personal data. 
To change this setting: 

1. Go to Edit > Preferences > Integrated Applications > Company Preferences (this is the location 
in most versions of QuickBooks. Consult your QuickBooks documentation if Company 
Preferences is not found on this path for your version). 

2. Click on Corrigo Integration (under Application Name). 

3. Click the Properties button. 

4. Click the Access Rights tab atop the Properties edit screen. 

5. Check each of the following settings: 

a. Allow this application to read and modify this company file 

b. Allow this application to access Social Security Numbers, customer credit card 
information, and other personal data 

Note: It is necessary to allow the Corrigo client access to personal data in order for the 
integration to export time cards; however, the integration client does not access or 
modify Social Security Numbers or customer credit card information. 

6. Click OK when done. 

Modifying these settings will allow the Corrigo Integration client access to the necessary data files in 
QuickBooks. 
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Note: While running the integration client, if you receive the message: 

“Application doesn’t have access to QuickBooks personal data. Please correct this and click Next to 
continue” 

then you have not correctly set the QuickBooks settings described in this section. Re-check the settings. 
You do not need to cancel the integration process to change the settings. 
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Figure 9: Select Properties for the Corrigo Integration client (top), then check the access 

settings (bottom), under the QuickBooks Access Rights tab (sample above from QuickBooks Premier 

2007). 

Launching the Setup Wizard 

If you just completed installation of the Corrigo Integration Client, the setup wizard will launch 
automatically the next time you start QuickBooks. If the wizard doesn’t start or you cancel it for any 
reason, you can start it manually by selecting File > Corrigo Integration > Settings from the QuickBooks 
menu bar. 
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Figure 10: Select File > Corrigo Integration > Settings within QuickBooks to manually launch the 

Initial Synchronization Setup Wizard 

Vista Users Note: If  Corrigo Integration does not appear in your QuickBooks File menu, then you may 
have installed the integration client improperly. Please see Running the Corrigo Integration Client on 
Vista in this guide for details. 

Using the Setup Wizard 

The wizard will walk you through each step of setting up your integration client. The first screen that 
appears will be General Synchronization Settings.  
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General Synchronization Settings 

Basic Settings 

 
Figure 11: Basic General Settings screen of the Initial Synchronization Setup Wizard 

General Settings: You will be asked how the integration client should decide conflicts if updates have 
been made to the same item in both systems prior to synchronization. 

If updates are made to the same information in both systems, decide which information will remain 
unchanged: 

• QuickBooks Wins: QuickBooks updates remain unchanged; Service Management updates will 
be changed by synchronization to match QuickBooks. 

• WorkTrack Wins: Service Management updates remain unchanged; QuickBooks updates will be 
changed by synchronization to match Service Management. 

• Manual: You will be given the chance to decide which updates will change if conflicts exist. 
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Next, choose how often you should be prompted to synchronize the two systems. One day is the 
minimum as well as default time that the system will remind you to synchronize. 

Note:  You can manually synchronize at any time by selecting File > Corrigo Integration > Synchronize 
from the QuickBooks menu when logged in as an administrator. 

Backup Settings: The repository is a file on your computer that contains a record of information you have 
synchronized. If this file is deleted or corrupted, you will need to restore it from a backup in order to 
recover mappings and associations that you’ve made in past synchronizations. Choose where and how 
often to create a backup of your repository. 

Once the Initial Setup Wizard is run, you can also manually backup the repository file at any time by 
accessing File > Corrigo Integration > Settings > General Settings > Create Backup from within 
QuickBooks. 

Advanced Settings 

 
Figure 12: Advanced General Settings screen of the Initial Synchronization Setup Wizard 

 

On Demand Sync Settings:  

On Demand sync settings help you enable or disable real-time sync. That is if On Demand sync is turned 
on any edits or additions you make to your customer and items in QuickBooks will be automatically 
reflected in Service Management without you having to run the sync explicitly. But for any changes that 
have been made to customer or items in Service Management to get across to QuickBooks you will have 
to run the sync explicitly.  
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This gives total control to you bookkeeper as they don’t need to worry about keeping the changes that 
they make in QuickBooks be in sync with Service Management. At the same time they have full control 
over what gets into QuickBooks. 

Who should turn off On Demand sync? 

If you have multiple work zones created in Service Management and would like to put customers you 
create in QuickBooks into specific work zones please turn off On Demand sync. Otherwise On Demand 
sync will use the default work zone that is defined in synchronization settings for all the new customers 
you create in QuickBooks. 

Automatic Customer:Sites/Jobs Update: 

If you want QuickBooks to get automatically updated whenever a Site/Job is created or edited in 
WorkTrack, you need to select ‘Yes’ for this setting. If you select ‘No’, updates will be synced up only 
when you explicitly run the synchronization. 

This functionality is mainly introduced to cover the scenario where you might create a new site/job for a 
customer in WorkTrack while creating a work order and you need to add a PO for that site/job 
immediately in QuickBooks. Hence this automatic process will run only if the customer:sites/jobs to be 
updated is less than or equal to 50 records. 

Automatic Sites/Jobs process will run only on one computer at any point of time when you are working 
in a network share environment.  

For example if computer A and B have integration client installed and are accessing the same QuickBooks 
company file on a server and if automatic customer:sites/jobs sync process started on computer A, a 
warning message will be displayed in computer B that automatic process is running in the background 
on computer A and that explicit sync or settings change cannot be done at that point. You will be able to 
perform any settings change or run sync after the “lock down” period of 20 minutes. 

Note: Once you make any change to this setting, please close QuickBooks and open it again for the 
change in configuration to take effect. 

Click Next when done. 
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WorkTrack Login Settings 

On the next screen, enter the Authentication code and WorkTrack Service Management company name.  

 
Figure 13: Enter the login information you use to access the Service Management web application 

You can get the authentication code and company name by logging into your Service Management 
application and navigating to Settings�Company�Integration Settings. 
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Figure 14: Integration settings in Service Management application 

Click on ‘Edit’ link for Integration Client Authentication Code, enter the code and re-enter to confirm and 
click on Save. Note the company name displayed on the screen. 

Enter the authentication you set and the company name in the authentication settings screen in 
Integration settings wizard. 

Note: Clicking Next after entering this information will validate your authentication with Corrigo. You 
must be connected to the Internet in order to proceed. 

Customer Synchronization Settings 

On this screen, you will decide how customer records will synchronize.  

For Customers Imported from QuickBooks into WorkTrack Service Management: Assign Service 
Management customer types, work zones, and service packages to the new customers from QuickBooks. 

QuickBooks does not use work zones or service packages in its customer records When customers created 
within QuickBooks are exported into Service Management, they will be added using the work zone and 
service package you select. QuickBooks customers of all types will be added to Service Management 
using the default customer type you select (choose between either Residential or Commercial). 
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Figure 15: Customer Synchronization Settings 

For Customers Imported from WorkTrack Service Management into QuickBooks: Assign QuickBooks 
customer types to the new customers from Service Management.  
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Two customer types exist within Service Management: Residential and Commercial. Since QuickBooks 
supports additional customer types, you need to decide how the two Service Management types will be 
mapped for customers imported into QuickBooks. You can select a QuickBooks customer type from the 

drop-down menu  or click the icon  next to each drop-down to create a new customer type in 
QuickBooks. 

 

 
Figure 16: Select customer type (left) from drop-down , or click the  icon to create a new 

type (right) 

Select how you want your customer list synchronized? Based on number of levels you select here 
Service Management will import jobs from QuickBooks in order to set up customer sites. Once you 
complete the Initial Synchronization Wizard, this setting cannot be changed. 

If you pick Customers and 2 levels of jobs here’s how your customer and jobs will be created as customer 
and sites in WorkTrack: 

Example: 

QuickBooks Customer and Jobs WorkTrack Customer and Sites 

ABC Super Market 

 Foster City Store 

  1600 Hillsdale 

  720 Sea Spray 

 Belmont Store 

ABC Super Market 

123 Sea Spray ln (this is the default Site 
that will be created with the address 1 field 
of the shipping address of that customer) 

 Foster City Store 

 Foster City Store:1600 Hillsdale 

 Foster City Store:720 Sea Spray 
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QuickBooks Customer and Jobs WorkTrack Customer and Sites 

 Belmont Store 

Item Synchronization Settings 

On the next screen, you will select defaults for service, non-inventory, and inventory part items. These 
item types are the only QuickBooks types supported in the web application’s Price List categories. 

 
Figure 17: Item synchronization settings example 
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First, select the QuickBooks accounts that should be used as default accounts for service and non-
inventory part items exported from Service Management. 

Next, associate Service Management Price List categories with QuickBooks items. These associations will 
be used to set up QuickBooks items imported into Service management. When associating Price List 
categories with QuickBooks Items: 

• Each QuickBooks Item must each be associated with at least one (or more) Price List category 

• Each Price List Category must be associated with only one QuickBooks Item (Service, non-
inventory, or inventory parts) 

Price list categories must exist within the web application in order for this integration setup to be 
completed. You may add a new Price List category to Service Management from this screen if necessary.  

Pick a default Tax Agency that you want to associate the sales tax items and groups created in Service 
Management. Sales tax items and groups that you created in Service Management will get the agency you 
select here as the associated tax agency when these items are exported to QuickBooks. 

Note: You cannot use the same Price List category for multiple QuickBooks item types. For example, once 
you have selected a Price List category to associate with QuickBooks Service Items, that category will not 
be available to select for Non-inventory Part Items (and vice versa).  You may, however, unselect the 
category to make it available again. 

Inventory Item Synchronization 

Service Management allows you to synchronize QuickBooks inventory items for inventory tracking. 
Inventory Items are items for which you track quantities purchased, on-hand, and sold. You can create 
inventory items in QuickBooks and export them into Service Management. Some notable features: 

• The Corrigo Integration Client will import QuickBooks Inventory items into Service 
Management, in addition to Services and Non-Inventory items 

• Inventory item name, description and sale price will import (other inventory related fields will 
not be synchronized) 

• The Integration Client items settings grid will allow you to associate QuickBooks inventory items 
with Service Management price list categories 

• The Integration Client will check to see if Inventory setting is enabled in QuickBooks before the 
synchronization will function (see QuickBooks Settings for Inventory Tracking in this guide for 
details). 

• When Service Management invoices that include inventory items are exported to QuickBooks, 
the inventory item count is automatically decremented in QuickBooks 

Note: Items added directly to Service Management as Price List Inventory Items will not export into 
QuickBooks and cannot be used in Service Management invoices to decrement the QuickBooks inventory 
count. Inventory Items must be set up in QuickBooks initially, then exported to Service Management. 

Invoice Export Settings 

This screen allows you to select how invoices created in the web application are exported to QuickBooks.  
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Basic Settings 

You will be required to do only the basic settings in most cases.  

 
Figure 18: Invoice Basic settings screen 

Checking Invoice to be printed and Invoice to be e-mailed will activate these options in invoices 
exported to QuickBooks after the synchronization is complete. 

Note: If you check Invoice to be emailed, your customer contact records must include a valid email 
address or invoice synchronization will fail. 

Work Done Description: In Service Management, a Work Done description is pulled from the work 
order and reflected on the Service Management invoice as a separate note. In order for this work done 
information to appear on QuickBooks invoices, you must select Yes to indicate that you want to export 
the work done information. Next, select from the drop-down menu where you want the information to 
appear on the QuickBooks invoice (for example, as the first line item on the invoice). 
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Invoice Numbering Scheme: Invoices created in Service Management will have the same number as the 
work orders. So invoices exported to QuickBooks will have the Work Order number as the invoice 
number.  This sometimes could lead to duplicate invoice numbering if you also do some invoicing in 
QuickBooks directly. You can avoid that problem by choosing a numbering scheme that suite your needs. 

• Use WorkTrack Invoice Numbering – Select this option if you would only use WorkTrack for 
creating invoices. 

• Use QuickBooks Invoice Numbering – Select this option if you also use QuickBooks to create 
some invoices. This will pick the last invoice number in QuickBooks and will increment the 
numbering for all the invoices exported from WorkTrack. WorkTrack invoice number will be 
added in the memo field of QuickBooks invoice for cross-referencing. 

Populate Sales Rep Field:  You can populate the ‘Rep’ field in QuickBooks invoice, with the primary 
technician who did that work order, by selecting ‘Yes’ to this setting. 

Note: If a corresponding employee and or a sales rep are not defined in QuickBooks, you will have the 
option to create them in QuickBooks when you go through the synchronization wizard. 

Invoice Template: You can select default template in which you want the exported invoices from 
WorkTrack to appear in QuickBooks in this setting. 

Subtotal Item: In QuickBooks you can have several subtotal items whereas in WorkTrack there is only 
one. So the single WorkTrack subtotal item needs to be mapped to a QuickBooks subtotal item in order 
for the invoices to get exported.  

Discount Item: In QuickBooks you can have several discount items whereas in WorkTrack there is only 
one. So the single WorkTrack discount item needs to be mapped to a QuickBooks discount item in order 
for the invoices to get exported.  

Advanced Settings 
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Figure 19: Invoice Advanced settings screen 

You will be required to do the Advanced settings only if you had used WorkTrack system without 
QuickBooks integration turned on for a while. In such a scenario you will have three generic items called 
Labor, Parts and Misc. which you need to map to one of your other charge items in QuickBooks.  

You can select the appropriate QuickBooks item from the drop-down, or click the  icon to add a new 
other charge item to QuickBooks. 

Time Card Settings  

This section applies to companies using the Service Management Time Card module:  

The next screen to appear will be the Time Card synchronization settings screen. From this screen you 
will be able to: 

1. Configure Import of Customer:Site along with time records 

2. Configure default payroll items and hourly rates 
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Figure 20: Time Card synchronization settings screen 

Configure Import of Customer:Site along with time records 

Do you want to import Customer:Site information for time records imported from WorkTrack? Yes/No 

The default selection for this setting will be ‘No’. 

Choose ‘Yes’ if you do job costing in QuickBooks. Individual time records will be exported for each work 
order done on a customer:site. There could be several time records for a single day depending upon the 
number of jobs your technicians perform each day. The work order number will be added for reference in 
each time record in the notes field. 

Choose ‘No’ if you don’t do job costing in QuickBooks. Number of hours worked for the entire time 
period will be aggregated and will be exported as regular, overtime and double time.  

Configure default payroll items and hourly rates  
 
Configure default hourly rates for Regular, Overtime, and Double time hours worked for employees that 
need to be created in QuickBooks during synchronization. Each default rate must be associated with a 
QuickBooks payroll item name, which you can select from the drop-down menu. 

Note: Default payroll item settings will be used only when a new employee has to be created in 
QuickBooks during synchronization. The synchronization will not change the values that are already set 
for employees in QuickBooks. 
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If conflicts arise, such as if an employee in QuickBooks has a different rate or different payroll item 
specified, a warning will be displayed during synchronization. You will then be able to define payroll 
items for individual employees in a reconcile grid. 

Completing Initial Synchronization Wizard 

Click Finish when done. You will be given the option to review each of the settings. 

Note: If you need to adjust any of these settings after the wizard is completed, you may access the 
settings screen through File > Corrigo Integration > Settings from within QuickBooks. 

Advanced Settings 
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Synchronizing the Systems 

Overview 

Once the initial settings have been established, you can synchronize the two systems by utilizing a 
synchronization wizard. Integration can occur between the following items: 

• Customers (full synchronization) 

• Items (service, non inventory, inventory, sales tax items, sales tax groups, item groups) - (full 
synchronization with exceptions for inventory items) 

• Sales Tax Codes (association from Service Management to QuickBooks) 

• Invoices (one way synchronization – from Service Management to QuickBooks) 

• Payment Methods (mapping from Service Management to QuickBooks) 

• Payments (one way synchronization – from Service Management to QuickBooks) 

• Time Card – for Time Card users only (one way synchronization – from Service Management to 
QuickBooks) 
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Starting the Synchronization Wizard 

 
Figure 21: Welcome screen of the Corrigo Integration Client synchronization wizard 

Begin synchronization by selecting the synchronization wizard. To start the wizard, log into QuickBooks 
as an administrator and go to File > Corrigo Integration > Synchronize.    

Note: If you are running QuickBooks 2008, run the synchronization in single user mode (see Troubleshooting 
for details). If your company is running a supported version of QuickBooks other than 2008 in multi-user 
mode, make sure the user running a synchronization is logged in as an administrator and has rights to 
access external applications. See your QuickBooks documentation for information on how to set user 
rights. 

Select Next to begin the customer synchronization. 
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Sales Tax Synchronization 

 
Figure 22: Sales Tax Code retrieval screen 

The Retrieval of Changed Sales Tax Codes screen will show how many updated sales tax code records 
have been retrieved. When the retrieval is complete, you will be given the chance to review and reconcile 
any conflicts that may arise. 

Click Next to continue. The next screen to appear will be Sales Tax Code reconcile grid. 
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Figure 23: Sales Tax Code Reconcile grid 

Left column indicates all the sales tax codes you have defined in WorkTrack Service Management and the 
right column indicates all the codes you have defined in QuickBooks. You can click on ‘SELECT SALES 
TAX CODE’ and either select CREATE NEW or pick a code from the list to associate it with a QuickBooks 
sales tax code and vise versa. 

 
Figure 24: Reconcile grid showing associations 

Once you have made all the associations, the ‘Next’ button will be enabled and you can click on it to 
proceed to the next step. The next screen to appear will be Sales Tax Code association progress screen.  
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Figure 25: Sales Tax Codes sync in progress 

Successful association of Tax code is displayed in the progress screen. Please click on Next button to 
proceed to Sales Tax Item retrieval screen. 
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Figure 26: Retrieval of Sales Tax Items screen 

The Retrieval of Changed Sales Tax Items screen will show how many updated sales tax item records 
have been retrieved. When the retrieval is complete, you will be given the chance to review and reconcile 
any conflicts that may arise. 

Click Next to continue. The next screen to appear will be Sales Tax Items reconcile grid. 
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Figure 27: Sales Tax Items reconcile grid 

In the reconcile grid you can see the sales tax that are going into QuickBooks and those that are coming 
from QuickBooks into WorkTrack. You have the option to exclude an item from synchronization. You 

need to click on the sales tax item to select it and then click the ‘Do not synchronize’ icon ( ).  

Click Next to continue. The next screen to appear will be Sales Tax Items sync progress screen.  
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Figure 28: Sales Tax Items sync progress 

Successful sync of Sales Tax Items is displayed in the progress screen. Please click on Next button to 
proceed to Sales Tax Group retrieval screen. 
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Figure 29: Retrieval of Sales Tax Groups 

You can click on Next button to step through the reconcile step and the sync progress step similar to Sales 
Tax Item synchronization. 
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Customer Synchronization 

 
Figure 30: Corrigo Integration Client synchronization wizard as it transfers data between systems 

The Retrieval of Changed Customers screen will show how many updated customer records have been 
retrieved. When the synchronization is complete, you will be given the chance to review and reconcile 
any conflicts that may arise. 

Note: Customers added to or modified in QuickBooks are automatically synchronized with the web 
application if On Demand synchronization is turned on. You do not need to run the synchronization 
wizard for this to occur. To update QuickBooks with customer additions and changes that were made in 
the web application, you must run the integration client or turn on the automatic job sync settings in 
Advanced General settings. 

If you only want to run the customer synchronization and not go through the entire wizard, you can 
select ‘Synchronize only Customers:Jobs’ from File�Corrigo Integration menu. 

Click Next to continue. The next screen to appear will be the Customer Synchronization grid. 
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Figure 31: Corrigo Integration Client Customer synchronization grid 

The synchronization action that will be taken with each item is listed in the Action column as an icon. To 
change the action, click an item on the grid to highlight and select it. Action options available for a 
highlighted item are represented by active icons on the icon bar beneath the grid: 

  
Figure 32: Action icons 

To see which action the active icon represents, hover over the icon with your mouse pointer to read a 
pop-up description: 

 

Change the action for a highlighted item by clicking the appropriate icon on the icon bar. Scroll through 
and review each item on the grid.  
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For example: In Figure 28, Joe’s Restaurant is currently set to synchronize  (that is, it will import into 

QuickBooks). If you do not want this customer to import into QuickBooks, highlight the customer name 

in the list, then click the Do not synchronization icon  on the icon bar beneath the grid. This will 

change the action icon listed in the Action column. 

The integration client will automatically attempt to link customers that exist in both systems. If you want 
to change how customers have been linked, you may choose to link customers manually. 

To manually link customers, select a customer from each side of the customer grid, then click on the 
appropriate icon.  

1. Click the first customer you want to link from either the WorkTrack or QuickBooks side of the 
grid. 

2. Select the corresponding customer you want to link from the other side of the grid by holding 
down <Ctrl> and clicking on the customer name. 

3. Select which customer record information will be used when the customers are synchronized by 
clicking on the appropriate icon from the icon bar.  

 
Figure 33: Manual customer synchronization (hold down <Ctrl> while clicking the second 

customer) 
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In Figure 30, 3V Co. from the web application is being synchronized with 3V Company from QuickBooks. 
The user in this example is choosing to synchronize from QuickBooks, which means that customer 
information from QuickBooks will be used in both the web application and QuickBooks for this 
customer. 

Caution: Once customers from QuickBooks and the web application have been linked, they cannot be 
unlinked. 

Item Synchronization 

Once the customer synchronization is complete, click Next to begin the Item Synchronization. Click Next 
again once the retrieval is complete. This will produce the item synchronization grid. 

 
Figure 34: Corrigo Integration Client Item synchronization grid 

Scroll through the list of items and review.  

To stop the export of any item that is scheduled to export (synchronize), highlight the item then click the 

Do Not Synchronize icon  from the icon bar beneath the grid. 

To export any item that is set to not synchronize, highlight the item then click the Synchronize icon  or 

 (depending upon the direction of the export) from the icon bar beneath the grid. 
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Other action options are available. Highlight an item, then hover over active icons on the icon bar to 
produce a pop-up description of the action available. 

Note: Items added to or modified in QuickBooks are automatically synchronized with the Service 
Management web application. You do not need to run the wizard for this synchronization to occur. To 
synchronize item updates that were made in Service Management with matching items in QuickBooks, or 
to decrement inventory in QuickBooks that was sold through Service Management, you must run the 
integration client. 

Group Item Synchronization 

Once the item synchronization is complete, click Next to begin the Item Group Synchronization. Click 
Next again once the retrieval is complete. This will produce the item group synchronization grid as 
shown below. 

 
Figure 35: Corrigo Integration Client Group Item synchronization grid 

Scroll through the list of items and review.  
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To stop the export of any group item that is scheduled to export (synchronize), highlight the item then 

click the Do Not Synchronize icon  from the icon bar beneath the grid. 

To export any group item that is set to not synchronize, highlight the item then click the Synchronize icon 

 or  (depending upon the direction of the export) from the icon bar beneath the grid. 

Other action options are available. Highlight an item, then hover over active icons on the icon bar to 
produce a pop-up description of the action available. 

Note: Group Items added to or modified in QuickBooks are automatically synchronized with the Service 
Management web application. You do not need to run the wizard for this synchronization to occur. To 
synchronize group item updates that were made in Service Management with matching items in 
QuickBooks you must run the integration client. 

Click Next to proceed to the Retrieval of employees with approved invoices step. 

Retrieval of Employees with Approved Invoices 

This step in the synchronization wizard will appear if, “Do you want to populate the Sales Rep field…” 
field is set to ‘Yes’ in basic invoice settings in the integration settings wizard.  

 
Figure 36: Retrieval of employees with approved invoices  
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Click Next to proceed to the employee, sales rep mapping step. 

Associate WorkTrack employees with QuickBooks employees and Sales Reps 

 
Figure 37: Employee and sales rep mapping grid 

Employees with approved invoices will be retrieved and will be listed in WorkTrack column as in the 
screen shot above. If the employee/sales rep is already mapped names will appear in the respective 
columns otherwise ‘CREATE NEW’ option will be selected by default. You have to option to map 
employees/sales rep or create them as new in QuickBooks. Sales Rep initials will be auto-populated but 
you have the option to change it if needed.  

Invoices exported to QuickBooks will have sales rep initials populated in the Sales Rep field. 

Click on Next to proceed to Invoice retrieval step. 
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Invoice Export 

Invoice export is completed using the same method as customer synchronization. However, invoices are 
only exported from the web application into QuickBooks. QuickBooks invoices do not export into the web 
application. Invoices must have a status of Approved in the web application in order to be exported. 

 
Figure 38: Corrigo Integration Client Invoice synchronization grid 

You can choose to post invoices at a customer or a job level. This depends on the ‘Configure Posting 
Invoices’ setting in WorkTrack Service Management at Settings�Financial�Posting Invoices. Based on 
that setting invoices will be posted at the customer or job level. 

Pre-requisites for posting invoices to Jobs in QuickBooks: 

1. Pick ‘On Sites’ for the question ‘How would you like to post invoices?’ in 
Settings�Financial�Posting Invoices. 

2. You should have opted to sync both customers and jobs in Integration settings i.e. you should 
have selected ‘Yes’ to the question ‘Do you use jobs as locations in QuickBooks?’ in Customer 
settings in Integration Wizard Settings. 
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Notes Regarding Invoice Export 

Long Invoice Numbers: Invoices exported into QuickBooks will retain the same invoice number that was 
assigned in Service Management, except when the Service Management number is longer than eleven 
characters. Since QuickBooks does not support more than an eleven character invoice number, a longer 
Service Management invoice number will be truncated from left to right until it is shortened to eleven 
characters. For example, a Service Management invoice numbered: 

East-032108-0000007 

would be shortened to 

2108-000007 

The full Service Management invoice number will be included in the memo field of the QuickBooks 
invoice for easy reference. In this example, the QuickBooks invoice memo would appear as: 

 

During synchronization, you will receive a message informing you if invoice numbers have been 
truncated.  

 

You can change your Service Management invoicing scheme through Settings >Work Zone > Edit Work 
Zone >WO Numbering to avoid having numbers truncated. 

Invoice Discounts: When invoices with line item discounts are exported to QuickBooks, each item 
discounted will include a discount line item beneath it. If multiple, identical items are marked for 
discount, they will be subtotaled. A total discount line item for all identical items will appear beneath that 
subtotal. 
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Figure 39: Invoice details screen showing discount line items in Service Management 

 
Figure 40: Discounts in Service Management (top) will export to QuickBooks as a line item 

(bottom) 
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Note: Any changes made to invoices in QuickBooks will not reflect in the corresponding invoice within 
the web application. 

Payment Method Mapping 

In this step, payment methods created in the web application are mapped to payment methods within 
QuickBooks. For each web application payment method, choose the corresponding QuickBooks payment 
method from the drop-down options list. 

 
Figure 41: Corrigo Integration Client Payment Methods mapping grid 

Note: If you choose to Skip this synchronization, the option to export payment methods will appear 
again on the next synchronization. 

Changed Payments Import 

In this step, changed payments are retrieved from the web application then imported into QuickBooks. If 
you need to view or cancel an import, click to highlight a customer, then click the appropriate icon on the 
icon bar beneath the grid. 

A valid QBMS (QuickBooks Merchant Services) account is required in order to synchronize credit card 
payments. Visit http://www.quickbooksmerchantservice.com/ to set up a valid account for your 
QuickBooks company. 
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Note: Credit card security standards allow for only the last four digits of a credit card number to be 
stored on a computer system. Corrigo has implemented this standard in order to protect customers. Intuit 
implemented this security requirement in 2007 versions of the QuickBooks software. As a result, credit 
card payment synchronization with the Service Management web application is functional only for 
customers using 2007 (or later) versions of QuickBooks.  
 

 
Figure 42: Corrigo Integration Client Payment Import grid 

Click Next when done. The final screen of the Synchronization Wizard will appear. Click Finish when the 
synchronization is complete. 

Error Reconciliation 

The synchronization may fail for individual items during any stage of the process. If this happens, you 
can view the reason each item failed in order to correct the error. 
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Figure 43: Error messages during customer synchronization 

If errors occur during synchronization, the Warnings and Errors screen will appear once a particular 
stage of the synchronization process is complete. The messages will offer information on why the 
information did not synchronize. 

You have the option to save the error report to a formatted text file or print the error report. Save or print 
by choosing the appropriate icon in the lower left corner of the Warnings and Errors window. By saving 
or printing the error report, you can use it later to fix the integration errors. Once errors are fixed, you can 
try synchronization again.  

Note: You can also email the error report file created with the Save to File feature directly to Corrigo 
support if you need help in understanding or fixing errors. See Technical Support at the end of this guide 
for contact information. 

Automatic proceed to next step 

You will be automatically taken to the next step in the synchronization wizard after a delay of about 5 
seconds, if there are no items to synchronize. You will be required to take an action on the screen only if 
there are some items to synchronize. 
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Time Card Synchronization (for Time Card users) 

The Time Card synchronization step is a one-way transfer of data from Service Management to 
QuickBooks. It consists of two phases. 

During the first phase, full names of Service Management employees with approved time cards are 
compared with employee names in QuickBooks. The names are matched by exact spelling (capitalization 
and multiple spaces within a name are ignored). Two possible scenarios can occur: 

• If a match is found in QuickBooks for a Service Management Time Card employee with an 
approved time card, the corresponding names are associated in a synchronization grid. 

• No match is found. If this occurs, then the grid will allow you to: 
o Associate the Service Management Time Card employee with an existing QuickBooks 

employee 
<OR>  
o Add the Service Management Time Card employee to QuickBooks 

To change the association of a Service Management user with a QuickBooks user, select the QuickBooks 
employee from the drop-down menu in the QuickBooks column of the Employees association grid (see 
Figure 38). To add a user, select Create New from the drop-down menu. 

 

Note: Time Card employees being exported from Service Management must either exist in QuickBooks, 
be created in QuickBooks through the synchronization wizard, or be associated with existing QuickBooks 
employees. The Time Card Synchronization cannot continue until this step is completed. 

 

 
Figure 44: Employees association grid 
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Once the employee associations have been made, click Next to start the Retrieval of approved Time 
Cards. 

The next screen to appear will be the Time Cards Synchronization. On this screen, you can accept the 
Time Card records if no payroll items need to be specified, or return to Service Management and re-open 
the time card for editing.  

Approved time cards are retrieved as shown below if you had selected ‘No’ to the setting, ‘Do you want 
to import Customer:Site information for time records imported from WorkTrack?’. Note that there are no 
customer:site in the grid below. 

 
Figure 45: Retrieval of approved Time Cards processing 
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Approved time cards are retrieved as shown below if you had selected ‘Yes’ to the setting, ‘Do you want 
to import Customer:Site information for time records imported from WorkTrack?’. Note that there are 
customer:site information for each time record in the grid below. 

 
Figure 46: Retrieval of approved Time Cards processing including customer:job information 

If an employee needs a payroll item specified, the employee name will be marked with . This indicates 
that the hourly wage records either do not exist, are incomplete, or conflict between Service Management 
and QuickBooks for the highlighted employee. Click the Specify payroll items icon at the bottom of the 
grid to enter the correct hourly wage rate. This will produce an editing screen where you can correct any 
discrepancies (see Figure 40). 
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Figure 47: Time Card Synchronization (above) and Specify payroll items edit screen (below) 

Click OK when payroll items have been edited. Click Next to complete synchronization. 

 

Running Corrigo Integration in network share setup 

I f you work with QuickBooks in a multi-user mode in a network shared environment there might be 
need for more than one user to be responsible for running the integration. If that is the case then there is 
an advanced setting you need to do in order to enable the Integration Client to work in such an 
environment. 

You will be required to do the advanced settings only under the following conditions: 

You run QuickBooks in multi-user mode AND 

You have QuickBooks company file in a network shared folder AND 

You would like to have more than one person responsible for running the integration 

 
Follow these steps to set up Corrigo Integration in a network share environment: 

 
1. Download and install integration client on computer A 
2. Do the basic settings (refer Using Set up Wizard section for details) and complete initial sync 
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3. Copy the cnqb.mdb file from C:\Documents and Settings\All Users\Application 
Data\Corrigo\Corrigo Integration and paste it in a shared location. If you are using Vista, the 
path for cnqb.mdb file is C:\Users\All Users\Corrigo\Corrigo Integration\CnQb.mdb. 

4. Open settings and click on the CQ icon to open up the menu 

 
Figure 48: Advanced settings menu 
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5. Click on Advanced Settings 

 
Figure 49: Advanced settings dialog 

6. Check the ‘Override client repository location’ checkbox. (Note: If you are making this setting on 
Vista, you need to have administrative rights to configure this setting) 

7. Enter the path of the shared location where the cnqb.mdb was copied to 
8. Click on Ok. Now the Integration client will use the repository file that is placed in the shared 

folder in network.  
Note: The repository file is an access database that stores all mappings between WorkTrack and 
QuickBooks and synchronization details. 

9. Download and install client on computer B 
10. Note that computer B should also be using the same QB company file which is in the shared 

location. 
11. Repeat steps 4 to 7. 
12. The settings you made in computer A will automatically be populated in Computer B since the 

cnqb.mdb is now shared 
13. Step through the settings until you hit finish. 
14. Run the sync from Computer B 



  

Corrigo Integration Client for QuickBooks -- User Guide 62 

 

Running the Corrigo Integration Client on Vista 

Additional steps need to be taken in order to run the Corrigo Integration on a computer running 
Windows Vista. All steps are mandatory and cannot be skipped. 

Note: Corrigo Integration can only be run on Window Vista 32-bit. All QuickBooks versions have a 
critical issue on Windows Vista 64-bit that prevents ANY integrated application to connect with 
QuickBooks. 

Only QuickBooks 2007  and later versions support Windows Vista. All previous versions of QuickBooks 
are unsupported (see http://developer.intuit.com/developer/newsletter.asp?id=504 for additional 
details). 

 
System Requirements: 

1. Windows Vista Business or Ultimate 32-bit operating system is installed and updated.  
Note: Client will not run on any Vista Home edition. 

2. .NET Framework 1.1 installed and updated with latest service packs and fixes. 
3. .NET Framework 2.0 installed and updated with latest service packs or fixes. 

See http://www.microsoft.com/downloads if you need to update these files. 
Search Microsoft site on .NET Framework for information on how to download and install files. 

4. QuickBooks 2007 or greater installed. 

5. Important: Corrigo Integration Client for QuickBooks should NOT be installed. 

 
How to setup QuickBooks to run the Corrigo Integration Client: 

1. Launch QuickBooks and sign in as an administrator. 
2. Select Help > Update QuickBooks. 
3. Select the Update Now tab on the Update QuickBooks dialog. 

4. Click the Get Updates button. 
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Figure 50: Select Help -> Update QuickBooks, then select the Update Now tab  

 
5. Once QuickBooks is updated, close the Update QuickBooks window. 

6. Close QuickBooks. 

7. Launch QuickBooks again as Administrator. Find QuickBooks shortcut either in the Windows 

Run menu or on desktop, right click on it and choose “Run as administrator” context menu item. 
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8. You will be asked if you want to install the recently downloaded updates. Choose Yes. 

Note: You may be asked if you want to continue with the program and if you want to restart 
your computer following installation. Answer Yes to these questions. Also, allow all security 
program you may have to permit the update to run. 

9. Once the update is installed, close QuickBooks. 

10. Install the Corrigo Integration client (see Installing the Corrigo Client section in this guide). 

11. Start QuickBooks as administrator once more (see the step 7 for instructions how to start 

QuickBooks with administrator permissions), login into your company and close QuickBooks 

immediately. If you see the Corrigo Integration Initial Setup Wizard, close it. 

12. Start QuickBooks under the regular user by double-clicking on the QuickBooks shortcut. 
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Troubleshooting 

Frequently Asked Questions 

I installed the integration client on my computer running Vista, but Corrigo Integration does not 
appear in the File menu of QuickBooks.  Why? 

Before installing the client on Vista (Business and Ultimate versions only – Vista Home versions 
not supported), follow the instructions in this guide in the section Running the Corrigo 
Integration Client on Vista. If you have already installed the Corrigo Integration Client and did 
not follow instructions, you will need to contact Corrigo WorkTrack support (see support contact 
information at the end of this guide). 

I just added information in my web application, but it doesn’t appear in the synchronization wizard. 
Why? 

If you added information to the web application after the synchronization wizard was started in 
QuickBooks, the information will not appear in any synchronization grid. You must exit the 
wizard and re-start it. 

I receive a message that states, “The previous version of Client Data Repository (CnQb.mdb) has been 
found…” while installing the Corrigo Integration Client. 

The repository is a file containing information from previous integrations. If you want to retain 
synchronization information from previous integrations, select Yes. Select No if you want to 
create a new, empty repository. You may want a new repository if you are integrating with a new 
QuickBooks company or if you are moving from a trial version of Service Management where 
you entered sample data that you do not want to retain. Contact Corrigo support if you are 
unsure of how to proceed. 

It appears as though I’ve installed the Corrigo Integration Client for QuickBooks successfully. 
However, when I log into QuickBooks, I don’t see the Corrigo Integration options on my menu. Why? 

In order to verify the installation and start the initial synchronization wizard, you must sign into 
QuickBooks as an administrator. 

I received the message “The company file cannot be closed at this time because there is another 
application (CorrigoNet Integration) which is using it.” Now my Corrigo Integration screen is not 
functioning correctly. Why? 

You have attempted to close QuickBooks while the Corrigo Integration client was running. You 
must close any of the Corrigo Integration forms prior to closing QuickBooks. If your integration 
client is not functioning correctly, close the client, then re-start it from the QuickBooks file menu. 

I just added a customer to QuickBooks and haven’t run the integration client. How come my customer 
already shows up in the web application? 
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Customers and items added to or modified in QuickBooks are automatically synchronized with 
the web application. You do not need to run the synchronization wizard for these updates to 
occur. To synchronize customer and item updates that were made in the web application, you 
must run the integration client. 

Shortly after starting the synchronization, I received the message “Application doesn’t have access to 
QuickBooks personal data. Please correct this and click Next to continue”.  How do I correct this 
problem? 

Time Card users must configure QuickBooks to allow the Corrigo Integration Client access to 
personal information. Go to Edit>Preferences>Integrated Applications>Company Preferences 
(for most versions of QuickBooks. Consult your QuickBooks documentation if Company 
Preferences is not found on this path for your version). To configure: 

1. Click on Corrigo Integration (under Application Name). 

2. Click the Properties button. 

3. Click the Access Rights tab atop the Properties edit screen. 

4. Check each of the following settings 

a. Allow this application to read and modify this company file 

b. Allow this application to access Social Security Numbers, customer credit card 
information, and other personal data 

5. Click OK when done. 

See QuickBooks Settings in this guide for additional information. 

While synchronizing QuickBooks 2008 with Service Management, I received the message: "There was 
an error when converting the percent [your tax rate] in the field "TaxRate" (“Error Code 3050). What 
should I do? 

You are running the synchronization in multi-user mode. Switch to single-user mode to run the 
synchronization, and invoices with non-zero tax will export. This is a known issue with 
QuickBooks 2008. 

I get ‘Exception occurred on QuickBooks request: This request cannot be processed from within data 
event callback procedure”. What should I do? 

This is an internal error thrown by QuickBooks. You can overcome this error by clicking on 
cancel and starting over the sync process again. 
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How to quickly send Corrigo, the Integration log files? 

Corrigo support will required the repository file from your computer in order to debug the 
problems you might have with integration. You can easily send us the file by click of a hyperlink. 
 
Open QuickBooks and click on File menu�Corrigo Integration�About 

Click on Send Client Repository to Corrigo hyperlink 

 
You will note the transfer progress bar and then a transfer complete message.  

Close the Transfer complete dialog and the about box. You would have successfully sent us the 
repository file. You will hear back from our support shortly after we analyze the logs. 
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Technical Support: 

Phone 

WorkTrack Service Management: 877-701-8326 (toll-free) 

Email 

support@corrigo.com 

 


